• Become a Subscribing Member today!

    The Biplane Forum is a large global active community of biplane builders, owners and pilots. From Pitts to Skybolts, to older barnstormers, all types are welcome.

    The Biplane Forum is a private community. Subscriptions are only $49.99/year or $6.99/month to gain access to this great community and unmatched source of information not found anywhere else on the web.

    Why become a Subscribing Member?

    • In addition to our active community, our content boasts exhaustive technical information which is often sought after for projects and maintenance. This information has accumulated over the 12+ years the forum has been in existence.
    • We are also a great resource for non biplane users, since many GA aircraft are built the same way (fabric and tube construction).
    • Annual membership also comes with two BiplaneForum.com decals.

    Become a Subscribing Member and access the Biplane Forum in full!

    Subscribe Now

Think I found my smoke issue!

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.
Joined
Oct 21, 2022
Messages
14
Reaction score
19
Location
Oklahoma
My new-to-me S-1S has a smoke system, but I noticed it's pretty anemic. It's controlled by a 2amp CB that keeps tripping, and when it does stay on, it's sporadic and never puts out much smoke. I poked around the other day and noticed I do have a line to each exhaust (yay!), but check out this fancy heavy duty pump I found in there:

https://www.holley.com/products/fue...umps/carbureted_electric_fuel_pumps/parts/12D

Some quick math gives a max flow rate of 0.58 GPM...............

Very low priority right now obviously, but at some point I'm gonna do this system up right and make some nice smoke!

Matt
 

Latest posts

Back
Top